Sudoku - Assistent

Sudoku Assistent Version: 1.7 (Build 20080820)

www.coufal.org/sudoku
© 2005,2008 Klaus Coufal (sudoku@coufal.org)

Einleitung

Dieses Programm soll Ihnen bei der Lösung von Sudoku-Rätseln helfen, es löst diese Rätseln nicht automatisch und stellt Ihnen auch nicht automatisch eine Aufgabe. Sie können jede Ihnen zur Verfügung stehende Aufgabe eingeben und anschließend die Hilfestellungen des Programmes benutzen, die primär aus der Anzeige der für die jeweilige Ziffer bereits blockierten Felder besteht. Weiters können für jedes Feld die noch möglichen Ziffern angezeigt werden und einige einfache Vervollständigungsfunktionen stehen ebenfalls zur Verfügung.
Wichtig: Die eingegebenen Ziffern werden erst durch Betätigung der "OK"-Schaltfläche oder einer der Ziffernschaltflächen übernommen.

Spielregeln
Fensterbeschreibung
Programmbedienung


Spielregeln

Die eigentlichen Spielregeln sind sehr einfach:
Das Spiel wird auf einem 9*9 Spielfeld, dass in 9 3*3 Subfelder eingeteilt ist, ausgeführt. In jedes der 81 Kästchen des Diagramms sind die Ziffern von 1 bis 9 einzutragen, wobei in jeder Zeile, in jeder Spalte sowie in jedem 3x3-Feld jede Ziffer genau einmal vorkommen darf.
Bei "X-Sudokus" gilt auch für die Diagonalen, daß jede Ziffer nur einmal vorkommen darf (diese Zusatzregel kann im Hauptfenster durch die Auswahl "X-Sudoku" aktiviert werden).
Einige der Ziffern sind bereits vorgegeben und die restlichen sind entsprechend den obigen Regeln einzutragen.

Beispiel:

2 |  |
 |  | 7
 | 1 |
3 | 6 | 5
 | 2 |
 |  | 9
8 |  |
 | 4 |
 | 9
4 |
 | 6

7 | 8
1 | 2

6 |
 | 3
9 |
 | 9 |
 |  | 5
3 |  |
 | 1 |
5 | 7 | 6

 | 5 |
2 |  |
 |  | 1

Fertiggestellt sieht es so aus:

2 | 8 | 4
9 | 5 | 7
6 | 1 | 3

3 | 6 | 5
4 | 2 | 1
8 | 9 | 7

7 | 1 | 9
8 | 6 | 3
5 | 4 | 2

1 | 3 | 9
8 | 4 | 2
5 | 7 | 6

7 | 4 | 8
6 | 5 | 9
1 | 3 | 2

6 | 2 | 5
1 | 3 | 7
9 | 8 | 4

7 | 9 | 1
4 | 6 | 5
3 | 2 | 8

2 | 8 | 4
9 | 1 | 3
5 | 7 | 6

3 | 5 | 6
2 | 7 | 8
4 | 9 | 1

Fensterbeschreibung
Programmbedienung
Übersicht


Sudoku - Fensterbeschreibung

Fensterbeschreibung

Hauptfenster | Hauptfenster bei "Alle Möglichkeiten" aktiviert
Sudoku Assistant - Hauptfenster | Sudoku Assistant - Hauptfenster mit Zusatzanzeige
Das Hauptfenster besteht aus dem 9*9 Spielfeld, den notwendigen Bedienelementen und einigen Zusatzanzeigen. Im 9*9 Spielfeld werden die schon eingegebenen Ziffern angezeigt bzw. weitere eingegeben.
Rechts neben dem Haupteingabefeld werden die Zeilensummen und unten die Spaltensummen angezeigt (bei korrekter Lösung sind alle 45). Unter den Ziffernschaltflächen sind die Anzahl der schon eingetragenen jeweiligen Ziffern vermerkt (bei korrekter Lösung 9); unter der Schaltfläche "-" wird die mit den Ziffernschaltflächen gewählte Ziffer dargestellt. In der nächsten Zeile ist die optionale Anzeige der Stoppuhr und die Gesamtzahl der eingetragenen Ziffern (bei korrekter Lösung 81) zu finden.
Danach kann noch die Option "X-Sudoku" gewählt werden (aktiviert die Zusatzregeln für die Diagnoalen) und es erfolgt die Anzeige der "Summe der Möglichkeiten", soferne das dazugehörige Fenster aktiviert ist. Die Summe der Möglichkeiten wird durch Addition der Anzahl der Möglichkeiten der 81 Felder gebildet und bildet nicht die verbleibenden Variationen des Sudokus ab (Der Wert beginnt bei 729 (9 Möglichkeiten in 81 Feldern) und endet bei 81 (nur mehr eine Möglichkeit pro Feld)).
Darunter werden, die zur Datei gehörigen Kommentare dargestellt, bzw. können editiert werden. Am unteren Rand befindet sich noch die Schaltfläche "OK", die zur Übernahme der Eingaben verwendet wird.
Zusätzlich kann noch - je nach Einstellungen - ein Tooltip eingeblendet sein, wenn sich der Cursor in einem leeren Ziffernfeld des Spielfelds befindet.


Programmbedienung

Die Eingabe von Ziffern erfolgt direkt in das jeweilige Feld (Auswahl mit der Maus, der <TAB>-Taste oder den Cursortasten ←, →, ↑, ↓, Pos1/Home und Ende/End), die Übernahme der eingegebenen Ziffern (und des Kommentars) resultiert aus der Betätigung der Schaltfläche "OK" oder einer der 10 (1..9,-) Ziffernschaltflächen. Das Löschen oder Ändern von Ziffern erfolgt auf dem gleichen Weg (Feld auswählen und neue Ziffer eingeben oder löschen). Selbstverständlich können auch mehrere Ziffern eingegeben (geändert, gelöscht) und auf einmal übernommen werden.
Mit Hilfe der Funktionstaste "F2" kann in das aktuelle Feld die aktuell ausgewählte Ziffer eingefügt werden.
Die Ziffernschaltflächen markieren alle Felder, in denen die jeweilige Ziffer nicht mehr vorkommen kann mit der gewählten Farbe (Nach Wahl alle Zeilen und Spalten, die Blöcke bzw. die besetzten Felder, in denen die Ziffer vorkommt). Die Schaltfläche "-" hebt die Markierung wieder auf.
Kommentare können im dazugehörigen Feld nach Belieben verändert (ergänzt, gelöscht) werden.
Achtung: Wenn Kommentare gespeichert werden, können Programmversionen vor 0.3 diese Dateien nicht mehr lesen!

Neben der Verwendung der Maus ist auch die Wahl der Schaltflächen und Menüpunkte mit der Tastatur möglich; durch Drücken der <ALT>-Taste werden die Buchstaben, die für einen Menüpunkt oder eine Schaltfläche notwendig sind, unterstrichen angezeigt (z.B.: Wird mit <ALT>-D das Dateimenü ausgewählt und mit <ALT>-1 die Ziffernschaltfläche 1 bedient.

Wenn ein Sudoku gelöst ist, können zwei Aktionen automatisch ausgeführt werden:
  1. Der Kommentar kann um einen Standardtext ergänzt werden, der unter "Extras/Einstellungen" eingegeben werden kann. Dieser Text kann auch Datum, Zeit und Stoppuhrinhalt übernehmen.
  2. Die Datei kann automatisch gespeichert werden, dabei kann ein fixer Text an den Dateinamen angehängt werden, um den Dateinamen mit der fertigen Lösung vom Dateinamen der Angabe unterscheiden zu können. Diese Option und der optionale Text können unter "Extras/Einstellungen" gewählt werden.
Tipp: Wenn Sie häufig Sudokus mit ähnlichen Kommentaren bearbeiten, kann mit Hilfe der Funktionstaste F12 oder des Menüpunktes "Datei/Neu (Kommentar kopieren)" das laufende Sudoku beendet und ein neues mit dem gleichen Kommentar begonnen werden, dabei wird ein im Kommentar vorkommendes Datum aktualisiert (d.h. auf das aktuelle Datum gesetzt bzw. wenn schon das aktuelle Datum im Kommentar steht, wird das Datum des nächsten Tages verwendet).

Die weitere Bedienung erfolgt über das Menü:
Datei
Bearbeiten
Extras
?

Übersicht
Kommandozeilenoptionen
Funktionstasten (F1, ...)
Einträge in die Registry


Datei

Neu

Der Menüpunkt "Datei/Neu" startet das Programm neu, dabei werden alle Felder neu initialisiert (Daten werden nicht übernommen). Wenn noch ungespeicherte Daten vorhanden sind, erscheint eine entsprechende Abfrage, sollten Sie diese mit der Schaltfläche NEIN beantworten, wird abgebrochen.

Neu (Kommentar kopieren)

Der Menüpunkt "Datei/Neu (Kommentar kopieren)" verhält sich i.a. genauso wie der Menüpunkt "Datei/Neu". Der Unterschied besteht darin, daß der Kommentar der vorhandenen Datei in die neue Datei kopiert wird und ein im Kommentar enthaltenes Datum (im Format TT.MM.JJJJ) aktualisiert wird (entweder mit dem heutigen Datum, oder wenn dieses bereits im Kommentar enthalten ist, mit dem Datum des nächsten Tages). Die Einstellung "X-Sudoku" wird ebenfalls übernommen. Die Funktionalität diese Menüpunkts steht auch mit der Funktionstaste "F12" zur Verfügung.

Öffnen

Der Menüpunkt "Datei/Öffnen" lädt eine Datendatei, in dem der in Windows übliche Dateidialog zur Auswahl einer Datei angezeigt wird. Sollten noch ungespeicherte Daten vorhanden sind, erscheint eine entsprechende Abfrage, sollten Sie diese mit der Schaltfläche NEIN beantworten, wird abgebrochen. (Dateien können auch mit Hilfe von "Drag-and-Drop" auf das Fenster oder das Programm gezogen werden; bei korrekter Installation des Programmes ist auch ein Doppelklick auf die Datendatei möglich, dies führt zum Start des Programmes und Laden der Datei).

Speichern

Der Menüpunkt "Datei/Speichern" speichert die vorhandenen Ziffern und Kommentare in die aktuelle Datei, dabei werden eventuell noch nicht übernommene Daten automatisch übernommen. Sollte noch keine Datei angegeben worden sein, wird nach einer gefragt (siehe "Speichern unter"). Bei korrekter Durchführung wird die alte Datei umbenannt (".bak.sudoku" wird an den Namen angehängt) und die neue unter dem aktuellen Namen abgelegt. Sollte dies nicht möglich sein, wird auf den "Speichern unter"-Dialog gewechselt.

Speichern unter

Der Menüpunkt "Datei/Speichern unter" speichert die Ziffern und Kommentare in eine neue Datei, dabei werden eventuell noch nicht übernommene Daten automatisch übernommen. Dazu erscheint der in Windows übliche Dateidialog, mit dessen Hilfe eine Datei ausgewählt werden kann, dabei ist die Eingabe des Names notwendig, die Erweiterung wird automatisch ergänzt. Sollte eine Datei des gewählten Namens bereits existieren, erscheint eine entsprechende Abfrage, sollten Sie diese mit der Schaltfläche Abbrechen beantworten, wird abgebrochen; wenn Sie hingegen mit der Schaltfläche Nein beantworten, wird der Dateiauswahldialog erneut angezeigt.

Drucken

Der Menüpunkt "Datei/Drucken" druckt die vorhandenden Ziffern und Kommentare mit Hilfe einer RTF-Datei. Eventuell noch nicht übernommene Ziffern und Kommentare werden automatisch übernommen. Dabei wird eine RTF-Datei (im Verzeichnis für temporäre Dateien des Benutzer) angelegt und dem Betriebssystem zum Drucken übergeben (je nach installierten Programmen erfolgt das Drucken mit WordPad, MS Word oder anderen Applikationen). Danach wird die RTF-Datei wieder gelöscht.

Als Webseite speichern

Der Menüpunkt "Datei/Als Webseite speichern" exportiert die vorhandenden Ziffern und Kommentare in eine HTML-Datei, dabei wird der Dateiname als Seitenname und Überschrift verwendet. Eventuell noch nicht übernommene Ziffern und Kommentare werden automatisch übernommen, danach erscheint der in Windows übliche Dateidialog, mit dessen Hilfe ein Dateiname für die HTML-Datei ausgewählt werden kann (ein eventuell vorhandener Dateiname wird dabei als Vorschlag benutzt), die Erweiterung wird - wenn notwendig - automatisch ergänzt. Sollte eine Datei des gewählten Namens bereits existieren, erscheint eine entsprechende Abfrage, sollten Sie diese mit der Schaltfläche Abbrechen beantworten, wird abgebrochen; wenn Sie hingegen mit der Schaltfläche Nein beantworten, wird der Dateiauswahldialog erneut angezeigt. Diese exportierte HTML-Datei kann jetzt mit einem Browser (z.B.: "Firefox") dargestellt werden.

Importieren

Der Menüpunkt "Datei/Importieren" erlaubt den Import von Sudokuangaben aus der Zwischenablage oder aus einer zu wählenden Datei. Das mögliche Format ist das im Internet häufig verwendete Angabenformat, bei dem alle Felder zu einer einzigen Zeichenkette zusammengefasst werden; für Leerfelder werden dabei entweder "0", ".", "-" oder ein Leerzeichen verwenden (welche Angabe für Leerfelder verwendet wird, ist für ein erfolgreiches Importieren irrelevant). Wichtig ist die korrekte Stellenanzahl von 81 (für jedes Feld eine), sonst erscheint eine Fehlermeldung. Sollten in einer zu importierenden Datei mehrere Angaben gespeichert sein, wird nur die erste zum Importieren verwendet (es wird nur die erste Zeile gelesen). In diesem Fall kann selbstverständlich mit Hilfe der Zwischenablage jede weitere Angabe extra importiert werden. Beispiele: 2..365..9..7.2.8...1.....4...97.86...4.....3...61.29...9.....5...5.1.2..3..576..1 oder 200365009007020800010000040009708600040000030006102900090000050005010200300576001 .

Exportieren

Der Menüpunkt "Datei/Exportieren" exportiert die geladenen Ziffern in die Zwischenablage, in eine Datei oder in das Internet, dabei wird das Internet häufig verwendete Format eines 81 Zeichen langen Textes benutzt und mit "." (in den Einstellungen änderbar) Leerfelder bezeichnet. Sollte für den Export eine schon vorhandene Datei verwendet werden, wird diese Zeichenkette an die Datei angehängt. Beispiel: 2..365..9..7.2.8...1.....4...97.86...4.....3...61.29...9.....5...5.1.2..3..576..1 . Für den Export in das Internet werden an den in den Einstellungen angegebene Internetlink die 81 Ziffern angehängt und dem Betriebssystem zum Öffnen eines Browsers übergeben. Wenn der Interlink in den Einstellungen noch nicht angegeben wurde, steht die Funktion "Datei/Export/Internet" nicht zur Verfügung; wenn der angegebene Internetlink nicht mit "http://" beginnt, erfolgt eine Fehlermeldung.

Beenden

Der Menüpunkt "Datei/Beenden" beendet das Programm.Wenn noch ungespeicherte Daten vorhanden sind, erscheint eine entsprechende Abfrage, sollten Sie diese mit der Schaltfläche NEIN beantworten, wird abgebrochen.

Menü Bearbeiten


Bearbeiten

Rückgängig

Der Menüpunkt "Bearbeiten/Rückgängig" löscht die Änderungen an den Ziffern bzw. Kommentaren durch die letzte Übernahme (Schaltfläche "OK" oder Ziffernschaltflächen). Dabei werden auch alle automatisch durchgeführten Ergänzungen seit der letzten Übernahme zurück genommen. Dieser Menüpunkt wirkt auf das Fenster "Alle Möglichkeiten" durch eine neuerliche Berechnung aller Möglichkeiten, wobei die vom Benutzer durchgeführten Änderungen in diesem Fenster verlorengehen. Sollte der Menüpunkt inaktiv (grau) sein, existieren keine Änderungen, die rückgängig gemacht werden können.

Vergleichen

Der Menüpunkt "Bearbeiten/Vergleichen" erfrägt eine zweite Sudoku-Datei und vergleicht diese mit der geladenen Datei. Dabei wird zuerst festgestellt, ob die beiden gleich oder ungleich sind und ob die vorhandene Datei eine Teil- oder eine Übermenge der zweiten Datei ist (Teil- bzw. Übermenge bedeutet, daß aus dem geladenen Sudoku nur durch Hinzufügen bzw. Wegnehmen von Ziffern die andere Datei gebildet werden kann). Die Ergebnisse werden anschließend analog zu folgendem Bild ausgegeben:

Darstellung eines Vergleichs

Dabei stammt die erste Ziffer aus der bereits geladenen und die zweite Ziffer aus der zu vergleichenden Datei. In der Statuszeile des Fenster steht eine Zusammenfassung des Ergebnisses des Vergleiches. Dieses Fenster kann jederzeit vom Benutzer geschlossen werden, ein automatisches Schließen erfolgt nur bei einem neuen Vergleich bzw. bei Beendigung des Programms.

Fixieren

Ziffern fixieren
Der Menüpunkt "Bearbeiten/Fixieren/Ziffern fixieren" fixiert alle schon übernommenen Ziffern, d.h. diese sind dann nicht mehr editierbar. Zur leichteren Erkennung werden diese Ziffern fett und mit grauem Hintergrund dargestellt. Dieser Menüpunkt kann auch öfter aufgerufen werden, um zusätzliche Ziffern in die Fixierung zu übernehmen.

Fixierung aufheben
Der Menüpunkt "Bearbeiten/Fixieren/Fixierung aufheben" hebt die Fixierung wieder auf, d.h. die Ziffern werden wieder in Normalschrift und mit normalem Hintergrund dargestellt und sind auch wieder änderbar. Auch wenn der Menüpunkt "Bearbeiten/Fixieren/Ziffern fixieren" öfter verwendet wurde, werden alle Ziffern wieder auf den Normalzustand zurückgesetzt.

Nicht fixierte Ziffern löschen
Der Menüpunkt "Bearbeiten/Fixieren/Nicht fixierte Ziffern löschen" löscht alle nicht fixierte Ziffern und kehrt damit wieder zum Stand der Fixierung zurück. Die gelöschten Ziffern können über den Punkt "Bearbeiten/Rückgängig" wieder hergestellt werden.

Menü Extras


Extras

Einstellungen

Der Menüpunkt "Extras/Einstellungen" erlaubt die Eingabe von Fertigstellungsaktionen, die Auswahl der Markierungsfarbe, des Markierungsumfanges, der Trennlinienstärke, der Trennlinienfarbe das Ein- und Ausschalten der Tooltip-Anzeige, das Ein-/Ausschalten der Funktionen für "Automatisch ergänzen" und noch einiger weiterer Parameter.

Fenster Einstellungen

Die Einstellungen im Detail

Speicherung der Einstellungen
Alle Einstellungen werden benutzerspezifisch in der Registry gespeichert und stehen auch beim nächsten Programmstart wieder zur Verfügung
(im Zweig HKEY_CURRENT_USER\Software\CKTools\sudoku)

Die Schaltflächen in diesem Fenster
OK | Damit werden die gewählten Einstellungen übernommen.
Abbrechen | Die veränderten Einstellungen werden nicht übernommen.
Export | Die Einstellungen werden aus Registry ausgelesen und in ein Datei geschrieben. Damit können die Einstellungen von einem Rechner oder Benutzer auf einen anderen übertragen werden, indem sie bei dem anderen importiert werden. (Nicht zu verwechseln mit dem Export von Sudokus im Menüpunkt "Datei".) Wenn der Dateiname die Erweiterung ".reg" hat wird der Export mit dem windowseigenen Registryeditor durchgeführt, sonst werden die Einstellungen in eine Ini-Datei mit der Erweiterung ".ini" geschrieben. Die Formate dieser beiden Dateiarten sind verschieden, daher kann ein .reg-Datei nur als .reg und eine .ini-Datei nur als .ini importiert werden!
Import | Die Einstellungen werden aus einer Datei (aus einem vorangegangenen Export) gelesen und in die Registry geschrieben. (Nicht zu verwechseln mit dem Import von Sudokus im Menüpunkt "Datei".) Wenn der Dateiname die Erweiterung ".reg" hat wird der Import mit dem windowseigenen Registryeditor durchgeführt, sonst werden die Einstellungen von einer Ini-Datei mit der Erweiterung ".ini" gelesen. Die Formate dieser beiden Dateiarten sind verschieden, daher kann nur in dem Format importiert werden, in dem der Export durchgeführt wurde!
Hilfe | Anzeige dieser Seite

Möglichkeiten des aktuellen Feldes

Der Menüpunkt "Extras/Möglichkeiten des aktuellen Feldes" zeigt die möglichen Ziffern für das aktive Feld an. Diese Anzeige verschwindet nach ca. 5 Sekunden wieder, außerdem können nur eine geringe Zahl dieser Fenster gleichzeitig angezeigt werden. Eine bequemere Gelegenheit die möglichen Ziffern anzuzeigen, bietet der unter "Extras/Einstellungen" wählbare Tooltip. Z.B.:
Anzeige der Möglichkeiten des aktuellen Feldes

Felder mit nur einer Möglichkeit

Der Menüpunkt "Extras/Felder mit nur einer Möglichkeit" zeigt alle Felder mit nur einer Möglichkeit in einen eigenen Fenster an. Diese Anzeige verschwindet nach ca. 5 Sekunden wieder. Z.B.:
Anzeige der Felder mit nur einer Möglichkeit

Alle Möglichkeiten

Der Menüpunkt "Extras/Alle Möglichkeiten" zeigt in einem eigenen Fenster für alle 81 Felder die Möglichkeiten bzw. die schon gefundene Ziffer an. Dieses Fenster wird durch erneuten Aufruf des Menüpunktes oder durch Übernahme von Ziffern im Hauptfenster aktualisiert. Die Felder mit den Möglichkeiten können editiert werden, die Felder mit fixen Ziffern sind nicht editierbar. Wenn aus einem Feld mögliche Ziffern manuell gelöscht werden, bleiben diese Ziffern auch nach einer Aktualisierung gelöscht. Bei Auswahl der Menüpunkte "Bearbeiten/Rückgängig" und "Bearbeiten/Fixieren/Nicht fixierte Ziffern löschen" müssen die Felder in diesem Fenster neu berechnet werden, dabei werden alle Änderungen durch den Benutzer zurückgesetzt. Wenn durch das Editieren in einem Feld nur mehr eine Ziffer verbleibt und die entsprechende Fertigstellenfunktion aktiviert ist, wird beim nächsten "Übernehmen" diese Ziffer in das entsprechende Feld im Hauptfenster kopiert.
Die Editiermöglichkeiten in den einzelnen Feldern:
Im Hauptfenster
 | F4 | aktuelle Ziffer im analogen Feld des Fenster "Alle Möglichkeiten" löschen
Im Feld selbst
 | F4 | aktuelle Ziffer im aktuellen Feld löschen
 | Entf (Del) | Ziffer rechts von der Einfügemarke löschen
 | ← (Backspace) | Ziffer links von der Einfügemarke löschen
 | <Zifferntaste> | entsprechende Ziffer im aktuellen Feld löschen (wenn vorhanden) oder einfügen (wenn nicht vorhanden)
Z.B.:
Anzeige aller Möglichkeiten

Zeitzähler

Mit dem Menüpunkt "Extras/Zeitzähler" kann eine interne Stoppuhr (mit der Genauigkeit von einer Sekunde) gesteuert werden, dies umfaßt drei Untermenüpunkte:

Anzeigen
Mit Hilfe dieses Menüpunktes kann die Anzeige der Stoppuhr ein- bzw. ausgeschalten werden. Wenn die Anzeige der Stoppuhr eingeschalten ist, wird dies durch ein Häkchen Anzeige Stoppuhr aktiviert vor dem Menüpunkt angezeigt. Auch wenn die Stoppuhr nicht angezeigt wird, läuft sie intern weiter, d.h. nur durch das Einschalten der Anzeige wird die Stoppuhr nicht auf Null gestellt. Die gewählte Einstellung (Anzeige der Stoppuhr ja/nein) bleibt auch bei der nächsten Verwendung von "Sudoku Assistant" erhalten.

Pause
Dieser Menüpunkt dient zum Anhalten bzw. Wiederaktivieren nach einem Anhalten der Stoppuhr. Die Funktionstaste "F3" kann als Alternative verwendet werden. Wenn eine Pause aktiv ist, wird dies durch ein Häkchen Pause Stoppuhr aktiviert vor dem Menüpunkt angezeigt.

Zurücksetzen
Mit diesem Menüpunkt wird die Stoppuhr auf den Ausgangswert "0:00:00" (=0 Stunden, 0 Minuten und 0 Sekunden) zurückgesetzt. Ein automatisches Zurücksetzen erfolgt beim Laden oder erstmaligem Speichern einer Datei.

Menü ?


Extras - Einstellungen

Markierungen

Hier können der Umfang und die Farbe der Markierungen bestimmt werden.

Reiter Einstellungen-Markierungen

Markierungsumfang
Zeilen/Spalten | Besetzte Zeilen und Spalten werden markiert
Blöcke | Besetzte Blöcke (3*3 Subfelder) werden markiert
Besetzt | Von Ziffern bereits besetzte Ziffernfelder werden markiert
Markierungen können beliebig kombiniert werden. Vorgabewert: die ersten beiden Punkte.

Markierungsfarbe
Auswahl der Farbe für die Markierungen, zur Verfügung stehen
blau | Blau
braun | Braun
gelb | Gelb
gruen | Grün
himmelblau | Himmelblau
kornblume | Kornblume
rot | Rot
silbergrau | Silbergrau
Vorgabewert: Rot

Trennlinien

Unter diesem Reiter können die Trennlinienstärke und die Trennlinienfarbe eingestellt werden. Diese wirken im Hauptfenster, im Alle-Möglichkeiten-Fenster und im Vergleichsfenster (im letzteren werden sie allerdings bei Änderungen nicht aktualisiert).

Reiter Einstellungen-Trennlinien

Trennlinienstärke
Auswahl der Dicke der Trennlinien:
Keine | Keine Trennlinien
Dünn | Dünne Trennlinien (so dünn, daß die Farbe nicht sichtbar ist!)
Mittel | Mitteldicke Trennlininen
Dick | Dicke Trennlinien
Vorgabewert: Keine

Trennlinienfarbe
Auswahl der Farbe für die Trennlinien, zur Verfügung stehen:
weiss | Weiss
silbergrau | Silbergrau
grau | Grau
schwarz | Schwarz
blau | Blau
dunkelblau | Dunkelblau
Vorgabewert: Grau

Möglichkeiten

Mit Hilfe diese Reiter kann die Anzeige der Möglichkeiten für die Felder gesteuert werden.

Reiter Einstellungen-Möglichkeiten

Anzeige der Möglichkeiten
Aktivieren durch Anwahl der Checkbox vor dem Wort "Tooltip" und Auswählen des Ortes für den Tooltip (=kleines Fenster mit dem möglichen Ziffern für das aktive Ziffernfeld bzw. keine Anzeige, wenn kein Ziffernfeld aktiv ist)
Oben | Das Tooltipfenster wird oben (Menüleiste) angezeigt
Bei den Ziffernfeldern | Das Tooltipfenster wird rechts unter dem betreffenden Ziffernfeld angezeigt (Überdeckt eventuell andere Ziffernfelder)
Unten | Das Tooltipfenster wird unten (Kommentarfeld) angezeigt
Aktiviert wird das Ziffernfeld durch einen Mausklick bzw. durch wiederholtes Betätigen der <TAB>-Taste. Vorgabewert: Tooltip inaktiv.

Freies Fenster für alle Möglichkeiten
Das Alle-Möglichkeiten-Fenster wird standardmäßig beim Öffnen an das Hauptfenster angebunden (je nach Platz links oder rechts davon). Durch die Auswahl dieser Option kann das Alle-Möglichkeiten-Fenster auch schon beim Öffnen überall am Schirm sein (die Position des Fenster bleibt auch bei der nächsten Verwendung erhalten). Vorgabewert: inaktiv.

Ergänzungen

Über diesen Reiter können einige automatische Ergänzungen für Felder dazugeschalten werden (Achtung: sehr einfache Sudokus werden dadurch automatisch gelöst).

Reiter Einstellungen-Ergänzungen

Automatisch ergänzen
Ergänzen aktiv | Wenn nicht gewählt, gelten keine Fertigstellungsfunktionen. Vorgabewert: aktiv.
Fertigstellen | wenn nur mehr Felder einer Ziffer fehlen, werden diese ausgefüllt
Zeilen/Spalten | Wenn nur mehr ein Feld in einer Zeile oder Spalte leer ist, wird dieses ausgefüllt
Blöcke | Wenn nur mehr ein Feld in einem Subfeld (3*3) leer ist, wird dieses ausgefüllt
Ziffern | Wenn von einer Ziffer bereits acht vorhanden sind, wird das neunte Feld gesucht und ausgefüllt
Felder | Wenn für ein Feld nur eine Möglichkeit existiert, wird diese eingesetzt
 | (Diese Funktion wirkt auch, wenn im Alle-Möglichkeiten-Fenster nur mehr eine Möglichkeit existiert)
Fertigstellungsfunktionen können beliebig kombiniert werden. Vorgabewert: kein Punkt ausgewählt.

Anmerkungen:
  • Je mehr Optionen ausgewählt sind, desto problematischer wirken sich falsche Eingaben aus.
  • Bei Auswahl des Menüpunktes "Bearbeiten/Rückgängig" werden auch alle automatisch durchgeführten Ergänzungen seit der letzten Übernahme zurück genommen.

Aktionen

Hier werden die Parameter für automatische Aktionen nach dem Fertigstellen (Lösen) eines Sudokus festgelegt:

Reiter Einstellungen-Aktionen

Fertigstellungstext: | Hier kann Text eingegeben werden, der immer automatisch an den Kommentar angefügt wird, wenn ein Sudoku fertiggestellt wird. Sollte in dem Text die Zeichenfolge $D vorkommen, wird diese durch das aktuelle Datum (im windowseigenen kurzem Datumsformat) ersetzt (nur das erste Vorkommen wird ersetzt). Analog dazu wird $T durch die aktuelle Zeit und $Z durch den Wert der Stoppuhr ersetzt. Vorgabewert: Kein Fertigstellungstext.
Automatisches Speichern unter | Wenn diese Option gewählt ist und ein Sudoku fertiggestellt wird, wird die Datei automatisch gespeichert; sollte eine Datei gleichen Namens existieren oder kein Dateiname angegeben sein, wird ein "Datei/Speichern unter" angeboten. Vorgabewert: Option ist nicht ausgewählt.
Anhang an den Dateinamen: | Beim automatischen "Datei/Speichern unter" beim Fertigstellen eines Sudokus wird der Dateiname um diesen Text erweitert. Z.B.: "-fertig" erzeugt aus dem Dateinamen "test.sudoku" beim automatischen Speichern den Dateinamen "test-fertig.sudoku"). Vorgabewert: Kein Anhang.

Sonstiges

Die Einstellungen ohne Kategorie können in diesem Reiter vorgenommen werden.

Reiter Einstellungen-Sonstiges

Zeitdauer der Nachrichtenfenster in Sekunden
Viele Nachrichtenfenster haben einen automatischen Zeitablauf, nachdem sie wieder verschwinden. Diese Zeitdauer kann hier verändert werden. Gültige Werte sind ganze Zahlen zwischen 1 und 99.
Vorgabewert: 5

Zeichen für Leerfelder beim Export von Sudokus
Beim Exportieren von Sudokus wird ein Zeichen für die Felder ohne Ziffern (Leerfelder) verwendet. Dieses Zeichen kann hier eingestellt werden. Gültige Zeichen sind alle Zeichen ausgenommen der Ziffern 1 bis 9.
Vorgabewert: "."

Internetlink für den Menüpunkt Export/Internet
Hier wird der Link angegeben, der für den Menüpunkt "Datei/Export/Internet" verwendet wird. Dieser muß mit "http://" beginnen und so aufgebaut sein, daß die Ziffern dahinter angehängt werden können und als Ergebnis noch ein gültiger Link entsteht. Vorgabewert: Kein Link

Menü Extras


?

Hilfe

Der Menüpunkt "?/Hilfe" (oder die Funktionstaste F1) startet die externe Hilfe zu diesem Programm oder wenn diese nicht installiert ist, wird eine interne Kurzfassung angezeigt.

Info

Der Menüpunkt "?/Info" zeigt allgemeine Programminformationen an und bietet Links zur Anzeige der Lizenz bzw. zur Homepage des Programmes an.

Menü Datei


Funktionstasten

Gültige Funktionstasten im Hauptfenster
 | F1 | Hilfe
 | F2 | aktuelle Ziffer in aktuelles Feld einfügen
 | F3 | Pause ein/aus
 | F4 | aktuelle Ziffer im analogen Feld des Fenster "Alle Möglichkeiten" löschen
 | F12 | Menüpunkt "Datei/Neu (Kommentar kopieren)"
Gültige Funktionstasten im Fenster "Alle Möglichkeiten
 | F4 | aktuelle Ziffer im aktuellen Feld löschen
 | Entf (Del) | Ziffer rechts von der Einfügemarke löschen
 | ← (Backspace) | Ziffer links von der Einfügemarke löschen
 | <Zifferntaste> | entsprechende Ziffer im aktuellen Feld löschen (wenn vorhanden) oder einfügen (wenn nicht vorhanden)


Kommandozeilenoptionen

Unterstützte Optionen (Nur eine Option ist möglich):
 | /debug | Programm startet im Debugmode
 | /p datei | Druckt die Datei datei
 | /log datei | Schreibt ein Protokoll in die Datei datei
 | datei | Öffnet die Datei datei


Einträge in die Registry

Globale Einstellungen unter HKEY_LOCAL_MACHINE\SOFTWARE\CKTools\Sudoku
 | Name | Typ | Beschreibung
 | Desktop | REG_DWORD | Desktoplink bei der Installation (0=Nein, 1=Ja)
 | Install_Dir | REG_SZ | Verzeichnis in das das Programm installiert wurde
 | Name | REG_SZ | Name des Programmes
 | QuickLaunch | REG_DWORD | Quicklaunchlink bei der Installation (0=Nein, 1=Ja)
 | Version | REG_SZ | Genaue Versionsbezeichnung des installierten Programmes
Benutzerspezifische Einstellungen unter HKEY_CURRENT_USER\Software\CKTools\sudoku
 | Name | Typ | Beschreibung
 | AP_Float | REG_DWORD | Freies Fenster für alle Möglichkeiten (0=Aus, 1=Ein)
 | AP_StartX | REG_DWORD | X-Wert der linken oberen Ecke des Fensters für alle Möglichkeiten
 | AP_StartY | REG_DWORD | Y-Wert der linken oberen Ecke des Fensters für alle Möglichkeiten
 | Autocomplete | REG_DWORD | Fertigstellen, wenn nur eine Ziffer fehlt (0=Aus, 1=Ein)
 | AutocompleteAll | REG_DWORD | Fertigstellen (0=Aus, 1=Ein)
 | AutoSaveAs | REG_DWORD | Automatisches "Speichern Unter" bei Lösung einer Aufgabe (0=Aus, 1=Ein)
 | Blockcomplete | REG_DWORD | Fertigstellen, wenn 8 Ziffern in Block (0=Aus, 1=Ein)
 | CMP_StartX | REG_DWORD | X-Wert der linken oberen Ecke des Fensters beim Vergleich
 | CMP_StartY | REG_DWORD | Y-Wert der linken oberen Ecke des Fensters beim Vergleich
 | ColorMark | REG_BINARY | Farbe zum Markieren
 | Columncomplete | REG_DWORD | Fertigstellen, wenn 8 Ziffern in einer Reihe oder Spalte sind (0=Aus, 1=Ein; bei X-Sudoku auch bei Diagonalen)
 | DefaultDataPath | REG_SZ | Pfad zum Öffnen und Speichern von Dateien
 | ExportCharacter | REG_SZ | Zeichen für Leerstellen beim Exportieren von Sudokus
 | FieldComplete | REG_DWORD | Fertigstellen, wenn nur eine Möglichkeit für ein Feld existiert
 | FileNameAppend | REG_SZ | Beim automatischen Speichern bei Lösung wird der Dateiname mit diesem Text erweitert
 | FrameColor | REG_BINARY | Farbe der Rahmen um die 3*3 Blöcke
 | FrameWidth | REG_DWORD | Dicke der Rahmen um die 3*3 Blöcke (0=Kein Rahmen, 1=Dünner, 2=Mittlerer und 3=Dicker Rahmen)
 | Internetlink | REG_SZ | Link für Export - Internet
 | MarkBlocks | REG_DWORD | Markieren von Blöcken (0=Aus, 1=Ein)
 | MarkOccupied | REG_DWORD | Markieren besetzter Zellen (0=Aus, 1=Ein)
 | MarkRowsColumns | REG_DWORD | Markieren von Zeilen und Spalten (0=Aus, 1=Ein)
 | MsgBoxTimeOut | REG_DWORD | MessageBoxTimeout (Zeit, die Nachrichtenfenster sichtbar sind)
 | NumberComplete | REG_DWORD | Fertigstellen, wenn eine Ziffer achtmal vorkommt (0=Aus, 1=Ein)
 | StartX | REG_DWORD | X-Wert der linken oberen Ecke des Fensters
 | StartY | REG_DWORD | Y-Wert der linken oberen Ecke des Fensters
 | TextReady | REG_SZ | Fertigstellungstext
 | TimerActive | REG_DWORD | Anzeige der Stoppuhr (0=Nein, 1=Ja)
 | TooltipEnable | REG_DWORD | ToolTip (0=Aus, 1=Ein)
 | TooltipMode | REG_DWORD | ToolTipMode (Ort, wo der Tooltip angezeigt wird)

Sonstiges:
Zusätzlich noch die Keys, die für die Deinstallation notwendig sind, in "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sudoku" und die Keys, die für den Datentyp ".sudoku" notwendig sind in "HKEY_CLASSES_ROOT\.sudoku" und "HKEY_CLASSES_ROOT\SudokuDataFile".

Bei einer Deinstallation werden alle Keys außer den Benutzerspezifischen (HKEY_CURRENT_USER\Software\CKTools\sudoku für alle Benutzer, die das Programm verwendet haben) gelöscht.


Sudoku Assistent - Versionsentwicklung

Versionen von Sudoku Assistant

V1.7 20080820

Rahmen um die einzelnen 3*3-Felder ermöglicht, um die Lesbarkeit zu verbessern.
X-Sudokus (Sudokus, wo auch die Diagonalen jede der neuen Ziffern genau einmal enthalten müssen) sind möglich, dabei werden doppelte Ziffern in den Diagonalen als Widerspruch erkannt und beim automatischen Ergänzen, der Tooltip-Anzeige und beim "Alle Möglichkeiten"-Fenster die Diagonalen entsprechend berücksichtigt. X-Sudokus werden durch das Anfügen eines Flags (;@$XSudoku) in der Datei gekennzeichnet.
Das Ergebnis eines Vergleichs zweier Sudokus wird in einem eigenen Fenster dargestellt.
Das Alle-Möglichkeiten-Fenster neu gestaltet, alle Ziffern behalten fixe Positionen, ein direktes Editieren ist nicht mehr möglich, dafür stehen folgende Tasten im Fenster zur Verfügung:
Taste | Bedeutung
<F4> | Löscht die im Hauptfenster gewählte Ziffer (diese Taste funktioniert auch im Hauptfenster)
<Delete> | Löscht eine Ziffer rechts vom Cursor
<BackSpace> | Löscht eine Ziffer links vom Cursor
1,2,3,4,5,6,7,8,9 | Löscht die entsprechende Ziffer oder fügt sie ein
Wenn in einem Feld im Alle-Möglichkeiten-Fenster nur mehr eine Ziffer verbleibt, wird diese - soferne in den Einstellungen bei "Ergänzen" "Felder" gewählt ist - im Hauptfenster eingefügt.
Im Falle eines "Rückgängig" werden die Änderungen des Benutzers im Alle-Möglichkeiten-Fenster verworfen.
Beim Löschen der nicht fixierten Ziffern wird auch das Alle-Möglichkeiten-Fenster neu berechnet (Die Änderungen durch den Benutzer werden dabei verworfen).
Die "Summe der Möglichkeiten" wird im Hauptfenster angezeigt, wenn das "Alle Möglichkeiten"-Fenster offen ist.
Das Alle-Möglichkeiten-Fenster wurde in der Größe an das Hauptfenster angepaßt und ebenfalls mit optionalen Rahmen um die 3*3 Blöcke versehen. Dieses Fenster wird auch an da Hauptfenster "angehängt" (je nach Platz links oder rechts), Weiters kann durch eine Einstellung entschieden werden, ob dieses Fenster an das Hauptfenster angehängt wird oder eigenständig bleibt (in diesem Fall wird die Position im Gegensatz zu früheren Versionen auch über das Schließen beibehalten).
Bei Änderungen der Einstellungen werden keine automatischen Ergänzungen vorgenommen.
Der Menüpunkt Datei/Export wurde um den Eintrag "Internet" erweitert und in den Einstellungen wurde im Reiter "Sonstiges" der dazugehörige Link (muß "http://" enthalten) aufgenommen. Damit ist es möglich die Zahlen direkt an eine Webseite zu senden, da die 81 Ziffern im Exportformat an den angegeben Link angefügt werden und die gesamte Zeichenkette dem Betriebssystem zur Ausführung übergeben wird.
Umstellung des Einstellungsfensters auf 6 Tabs, die Trennlinien sind jetzt ebenfalls im Einstellungsfenster sowohl in ihrer Stärke als auch in ihrer Farbe veränderbar.
F12: Wenn in Kommentaren ein Datum vorkommt wird bei einem Neustart mittels F12 dieses Datum durch das heutige ersetzt. Sollte das ursprünglich Datum schon das heutige sein, wird zum Ersetzen das morgige Datum verwendet (Für Sudokus, die schon am Vorabend publiziert werden). Die Änderungen für F12 betreffen auch den Menüpunkt "Datei/Neu (Kommentar kopieren).
Behebung folgender Fehler (sollten bei intentionaler Verwendung nicht vorkommen):
  • Beim automatischen Ergänzen wurden auch nicht leere Felder automatisch ausgefüllt (Wenn eine Ziffer 8 mal vorkam, wurde das 9. Vorkommen immer eingefügt).
  • Bei Änderungen nach dem Speichern wurden diese nicht mehr als ungesichert erkannt.
  • Bei Laden eines Sudokus und dessen vollständig automatischer Fertigstellung wurde die Prüfung auf Fertig nicht durchgeführt.

V1.6 20060821

Stoppuhr eingebaut, deren Inhalt kann über das Menü (Extras/Zeitzähler/Zurücksetzen) auf Null gesetzt werden bzw. wird beim Laden oder erstmaligem Speichern einer Datei automatisch auf Null gesetzt. Der Wert der Stoppuhr kann mit $Z in den Fertigstellungstext übernommen werden. Die Anzeige des Zählers kann auch abgeschalten oder angehalten werden.
Im Fertigstellungstext kann auch $T für die Zeit verwendet werden
Funktionstasten eingebaut (F1...Hilfe, F2...aktuelle Ziffer in aktuelles Feld einfügen, F3...Pause ein/aus, F12...Menüpunkt "Datei/Neu" allerdings unter Erhalt des Kommentars).
Cursortasten (Links, Rechts, Hinauf, Hinunter, Pos1, Ende) eingebaut, diese gelten nur, wenn sich der Cursor in einem der Ziffernfelder befindet.
Name des temporären Druckfiles wird mit Hilfe des Dateinamens gebildet, soferne einer vorhanden ist.
Beim Menüpunkt "Datei/Speichern unter" wird jetzt ein eventuell vorhandender Dateiname vorgeschlagen, bei der Warnung, daß eine Datei überschrieben wird, gibt es jetzt drei Möglichkeiten: Ja (Überschreiben), Nein (erneute Anzeige des Dateiauswahldialoges) und Abbrechen (Abbruch ohne Speichern).
Beim Menüpunkt "Datei/Als Webseite speichern" wird jetzt ein eventuell vorhandender Dateiname vorgeschlagen (mit der Erweiterung .html), bei der Warnung, daß eine Datei überschrieben wird, gibt es jetzt drei Möglichkeiten: Ja (Überschreiben), Nein (erneute Anzeige des Dateiauswahldialoges) und Abbrechen (Abbruch ohne Speichern).
In den Einstellungen kann ein automatisches Speichern beim Fertigstellen des Sudokus aktiviert werden (Ist standardmäßig deaktiviert). Dabei kann ein Text angegeben werden, der an den Namen der Datei angehängt wird. (z.B.: "-fertig" erzeugt aus dem Dateinamen "test.sudoku" beim automatischen Speichern den Dateinamen "test-fertig.sudoku"). Sollte kein Dateiname vorhanden sein, wird der "Speichern unter"-Dialog angeboten.

V1.5 20060501

Importfunktion eingebaut (81-stellige Texte aus einer Datei oder der Zwischenablage).
Exportfunktion eingebaut (81-stellige Zeichenkette in eine Datei oder in die Zwischenablage).
(z.B.: 2..365..9..7.2.8...1.....4...97.86...4.....3...61.29...9.....5...5.1.2..3..576..1)
Vergleichsfunktion eingebaut (Erkennt Gleich, Ungleich, Teilmenge und Übermenge).
Verbesserung der Prüfung des Dateinamen bei "Speichern unter": Die Extension ".sudoku" wird an einen eingegeben Namen angehängt, auch wenn ein "." im Namen vorkommt (Nur wenn die Erweiterung schon .sudoku lautet wird keine zusätzliche Erweiterung angefügt).
Verbesserung der Prüfung auf Fertigstellung: Solange eine Inkonsistenz existiert, kann die Fertigstellung nicht ausgelöst werden.
Parameter zu Drucken eingebaut: mit "/p Dateiname" können Dateien gedruckt werden, damit ist auch das Ziehen von Dateien auf ein Druckersymbol zum Ausdrucken möglich (bisher wurde beim Ziehen auf ein Druckersymbol Notepad gestartet und die Datei als Text ausgedruckt). Die Installationsprozedur wurde auch dahingehend abgeändert, daß der entsprechende Registrykey angepaßt wurde.
Behebung der Fehler mit dem Fenster "Alle Möglichkeiten" im Zusammenhang mit dem Laden und Speichern von Dateien. Bei Laden einer Datei (über Menü oder Drag and Drop) wird ein eventuelles Fenster mit den Möglichkeiten geschlossen; beim "Speichern unter" wird der Titel des Fensters entsprechend angepaßt.
Verbesserung des Zusammenspiels zwischen den beiden Fenstern (ein Einfügen einer Ziffer im Hauptfenster fügt diese Ziffer auch in das Fenster "Alle Möglichkeiten" ein und streicht auch die dadurch wegfallenden Möglichkeiten; händisch gelöschte Möglichkeiten im Fenster "Alle Möglichkeiten" bleiben auch bei einem Update (durch "Extras/Alle Möglichkeiten") gelöscht.)
Rückgängig ist jetzt für beliebig viele Schritte möglich.
Parameter zum Schreiben eines Logfiles "/log Dateiname" eingebaut.
Import- und Exportfunktion für die Einstellungen (im Menüpunkt Extras/Einstellungen) eingebaut (kann *.ini- und *.reg-Dateien exportieren und importieren).
Kontextspezifische Hilfe im Fenster Extras/Einstellungen eingebaut.
Fixieren-Menü unter Bearbeiten eingebaut, damit können vorhandene Ziffern fixiert (sind nicht mehr editierbar) bzw. nicht fixiert werden. Daneben können noch alle nicht fixierte Ziffern gelöscht werden.

V1.4a 20060123

Tippfehler bereinigt.
Beim Drucken werden ebenfalls noch nicht übernommene Daten automatisch übernommen.
Fenster mit der Anzeige der Felder mit nur einer Möglichkeit ebenfalls mit einem Timeout versehen.

V1.4 20060122

Menüpunkt "Extras/Felder mit nur einer Möglichkeit" eingebaut (Zeigt alle Felder mit nur einer Möglichkeit an).
Menüpunkt "Extras/Möglichkeiten" in "Extras/Möglichkeiten des aktuelles Feldes" umbenannt
Die Funktion Fertigstellen erweitert, wenn es Felder mit nur einer Möglichkeit gibt, wird diese automatisch ergänzt; diese Funktion kann in den Einstellungen ein- und ausgeschalten werden.
Die Funktion Fertigstellen um einen zentralen Ein-/Ausschalter erweitert (alle Fertigstellenfunktionen werden auf einmal deaktiviert); diese Funktion kann in den Einstellungen ein- und ausgeschalten werden.
Beim Lesen/Schreiben von Dateien wird keine Fertigstellenfunktion ausgeführt (in Gegensatz zu den Versionen bis 1.3)
Fehler beim Speichern von Dateien behoben (Ein Abbruch wegen einer vorhandenen Datei und ein anschließendes "Speichern" hat die Datei überschrieben).
Menüpunkt "Extras/Alle Möglichkeiten" eingebaut (Zeigt in einem eigenen Fenster für alle 81 Felder die Möglichkeiten bzw. die schon gefundene Ziffer an).

V1.3 20051015

Automatische Ergänzung des Kommentars bei Fertigstellung eines Rätsels um einen beliebigen Text (ein $D darin wird durch das Datum ersetzt).

V1.2 20050814

Verbesserte Ausgabe der Daten als Webseite (3*3 Blöcke besser erkennbar)
Copyrighthinweis in die RTF-Datei aufgenommen (analog HTML-Datei)

V1.1 20050807

Ausgabe der Daten als Webseite eingebaut (Menüpunkt "Datei/Als Webseite speichern").
Farben der Zahlen vereinheitlicht:
  • Schwarz: Fixe und von Anwender eingegebene Zahlen und Ziffern,
  • Blau: Automatisch errechnete Zahlen und
  • Dunkelblau: Automatisch errechnete Zahlen, die Ihren Sollwert erreicht haben.
Hilfesystem verbessert.

V1.0 20050801

Programm umbenannt (von "Sudoku Helper" auf "Sudoku Assistant")
Die Funktion "Datei/Speichern" durch die Funktion "Datei/Speichern unter" ersetzt und die Funktion "Datei/Speichern" neu eingebaut (speichert unter aktuellem Dateiname wie andere Windowsprogramme auch; die vorhandene Datei wird umbenannt (Erweiterung ".bak.sudoku" wird angehängt) und die aktuellen Daten werden gespeichert).
Prüfung auf Widersprüche eingebaut (Eine Ziffer öfter als einmal in einer Zeile, Spalte oder Block wird als Fehler ausgegeben).
Die Funktion "Fertigstellen" erweitert, wenn eine Ziffer acht mal vorkommt, wird das neunte Vorkommen ergänzt; diese Funktion kann in den Einstellungen ein- und ausgeschalten werden.
Hilfe auf CHM-Format umgestellt und erweitert.
Den Timer für die Tooltipanzeige verbessert (Interaktionen zum sonstigen Programm waren vorher möglich).
Die Funktion "Fertigstellen" erweitert, wenn nur eine Ziffer pro Block (3*3) fehlt; diese Funktion kann in den Einstellungen ein- und ausgeschalten werden.
Eine Felddefinition geändert (Führte unter Windows 2000 zu einem unschönen Zeilenumbruch).

V0.9 20050728

Die Funktion Fertigstellen erweitert, wenn nur eine Ziffer pro Zeile/Spalte fehlt; diese Funktion kann in den Einstellungen ein- und ausgeschalten werden.
Fenster mit Einstellungen komplett überarbeitet und neue Einstellungen für die Anzeige der möglichen Ziffern in einem Feld als Tooltip (rechts oben; rechts unten; bei den Ziffernfeldern) vorgesehen.
Den Menüpunkt "Info" geändert und den Menüpunkt "Lizenz" in das Fenster "Info" verschoben. Einen Link in das Fenster "Info" aufgenommen.
Einen Fehler beim Bilden des Dateinamens im Punkt "Speichern" behoben (Wenn im Verzeichnis ein Punkt vorkam, wurde die Erweiterung .sudoku nicht ergänzt).
Fehler im Menüpunkt Drucken behoben (in den Ausdrucken waren Zeilen und Spalten vertauscht).
Beschränkung der Eingabe auf einstellige Zahlen in den entsprechenden Feldern.
Änderungen im Kommentar lösen die Meldung "Fertig" nicht erneut aus.

V0.8 20050721

Die Funktion Extras/Möglichkeiten eingebaut, diese Funktion führt zur Anzeige der möglichen Ziffern für das aktive Feld.
Die Funktion ?/Lizenz zur Anzeige der Lizenz eingebaut.

V0.7 20050720

Die Funktion Datei/Drucken eingebaut, dabei wird im temporären Verzeichnis eine RTF-Datei generiert, diese mit der Windows-Standardapplikation gedruckt und anschließend wieder gelöscht.
Für viele Menüpunkte Funktionstasten zur rascheren Bedienung eingebaut (z.B.: können die Ziffernschaltflächen mit ALT-<N> bedient werden (wobei N durch die entsprechende Ziffer ersetzt wird)).

V0.6 20050703

Funktion Fertigstellen eingebaut (wenn nur mehr Felder einer Ziffer fehlen, werden diese ausgefüllt)
Die Funktion kann im Menüpunkt Extras/Einstellungen ein- und ausgeschaltet werden.
Die Fensterposition des Programmes wird ebenfalls in der Registry vermerkt, um bei einem Neustart wieder an der zuletzt verwendeten Position beginnen zu können.
Verbesserung des Installers (Prüfung ob die Rechte vorhanden sind, schon zu Beginn)

V0.5 20050702

Abbrechen bei den Dateimenüs wird ausgewertet und führt zum Abbruch der Dateioperation.
Menüs statt der vielen Buttons:

Datei (Mit den Punkten: Neu | Öffnen | Speichern | Beenden)
Bearbeiten (Mit dem Punkt: Rückgängig)
Extras (Mit den Punkten: Einstellungen( | Debug))
? (Mit den Punkten: Hilfe | Info)

Einstellungen:
(Die Einstellungen werden in der Registry gespeichert: HKCU\Software\CKtools\sudoku)

Farbwahl für das Markieren (aus einer Auswahl)
Umfang für die Markierungen (Zeilen/Spalten | Blöcke | Besetzt)

Auch bei "Neu" wird auf noch ungespeicherte Daten geprüft.
Gesamtzahl der eingetragenen Ziffern wird angezeigt.
"Fertig" wird erkannt und eine entsprechende Meldung wird ausgegeben.
Anpassung des Hilfetextes.

V0.4 20050629

Der Default-Pfad zum Laden und Speichern wird in der Registry HKCU\Software\CKTools\sudoku\DefaultDataPath[REG_SZ]=<Pfad> abgelegt:

Vor jedem Laden/Speichern wird dieser Key gelesen;
Nach jedem Laden/Speichern wird dieser Key geschrieben;
Damit wird erreicht, daß der zuletzt verwendete Pfad vorgeschlagen wird (Benutzerspezifisch);
Auch ein Drag and Drop bzw. eine Datei beim Starten des Programms setzt diesen Key (das wird noch in der Praxis erprobt, ob dieser Punkt nicht ausgeschalten werden soll).

Verbesserung der Feststellung ungesicherter Daten:

Vor und nach dem Submit werden die Daten verglichen und nur bei ungleichen Daten wird das Flag gesetzt, daher auch bei einem impliziten Okay durch die Ziffernschaltflächen.

Schaltfläche "Zurück" eingebaut, um die letzte Änderung (durch OK oder Ziffernschaltflächen) zurückzunehmen.
Beim Laden von Dateien werden jetzt auch die hervorgehobenen Zeilen und Spalten richtig gestellt.
Verbesserung der Hilfe.

V0.3 20050625

Einführung von Kommentaren (Vorsicht! Wenn Kommentare verwendet werden, können Versionen vor 0.3 diese Dateien nicht mehr lesen (Löschen der Kommentare, macht diese Dateien auch für ältere Versionen lesbar), die auch in der Datendatei abgelegt werden (Kommentare sind dateispezifisch).
Beim Laden und Beenden wird davor gewarnt, wenn noch ungespeicherte Daten vorliegen.
Warnung vor dem Überschreiben von Dateien.
Doppelclick auf eine .sudoku-Datei wurde ermöglicht (Datei wird als Parameter übergeben und geöffnet). Drag and Drop von Dateien auf das Programmfenster wurde ermöglicht.
Erste Version mit Installer/Deinstaller.
Anpassung der Hilfe.

V0.2 20050618

Prüfung auf falsche Einträge in den Feldern (größer 9).
Fenstertitel enthält den Dateinamen.

V0.1 20050617

First public release.


Sudoku - Lizenz

Lizenz

"Sudoku Assistant" © 2005,2008 by Klaus Coufal (sudoku@coufal.org)

Lizenz für "Sudoku Assistant" V1.7

Hiermit wird jeder Person die Erlaubnis erteilt, dieses Programm ohne
Gebühr unter Beachtung der folgenden Einschränkungen zu verwenden.

DAS PROGRAMM WIRD IHNEN ZUR BENUTZUNG ÜBERLASSEN, SO WIE ES IST
UND OHNE IRGENDEINE FUNKTIONSGARANTIE. DIE VERWENDUNG ERFOLGT
AUF EIGENE GEFAHR, DER AUTOR ÜBERNIMMT KEINE HAFTUNG FÜR EVENTUELLE
SCHÄDEN, DIE DURCH DIE VERWENDUNG DIESES PROGRAMMS ENTSTEHEN.

Das Programm darf nur in der vorliegenden Form inkl. dieses Copyright-
Hinweises weitergegeben werden.
Für die Weitergabe dürfen keine Gebühren verlangt werden.
Das Programm darf nicht zurückentwickelt oder verändert werden.

Die Urheberrechte verbleiben beim Programmersteller.

Internationale Fassung des Gewährleistungsausschlusses:

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
IN NO EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES
OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.